RCE with exploit in Confluence Server and Confluence Data Center (CVE-2021-26084)

On August 25, Atlassian reported a critical Remote Code Execution vulnerability in Confluence Server and Confluence Data Center. The vulnerability allows an authenticated user, and in some cases an unauthenticated user, to execute arbitrary code in Confluence Server and Confluence Data Center.

Today, September 1, an article was published with a research of the vulnerability and code that can be used to exploit it. Later, based on information from this article, an exploit was published for Confluence Server versions earlier than 7.12.4. The exploit can be used to attack Linux servers.

Vulnerable versions: All versions up to 6.13.23 6.14.0 – 7.4.11 7.5.0 – 7.11.6 7.12.0 – 7.12.5

Latest versions of products by link

Check if your Confluence server has Internet access and if so, why?

Everyone urgently needs to update!

Leave a Reply